import Foundation
let pattern = ##"\B#([a-fA-F0-9]{6}|[a-fA-F0-9]{3})\b"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
#fff
#fefefe
#242424
#24ff33
#24ff3o //o is not a valid hex value
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)