$re = '/\B#([a-fA-F0-9]{6}|[a-fA-F0-9]{3})\b/';
$str = '#fff
#fefefe
#242424
#24ff33
#24ff3o //o is not a valid hex value';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);