const regex = /\B#([a-fA-F0-9]{6}|[a-fA-F0-9]{3})\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\B#([a-fA-F0-9]{6}|[a-fA-F0-9]{3})\\b', 'g')
const str = `#fff
#fefefe
#242424
#24ff33
#24ff3o //o is not a valid hex value`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}