// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\B#([a-fA-F0-9]{6}|[a-fA-F0-9]{3})\b").unwrap();
let string = "#fff
#fefefe
#242424
#24ff33
#24ff3o //o is not a valid hex value";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}