package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\B#([a-fA-F0-9]{6}|[a-fA-F0-9]{3})\b`)
var str = `#fff
#fefefe
#242424
#24ff33
#24ff3o //o is not a valid hex value`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}