re = /https?:\/\/(www\.)?([a-zA-Z0-9]+)(\.[a-zA-Z0-9.-]+)/m
str = 'https://www.google.com
https://regex101.com/
https://www.youtube.com/
https://www.udemy.com/
https://tm.udemy.com/
https://lms.netacad.com/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end