using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https?://(www\.)?([a-zA-Z0-9]+)(\.[a-zA-Z0-9.-]+)";
string input = @"https://www.google.com
https://regex101.com/
https://www.youtube.com/
https://www.udemy.com/
https://tm.udemy.com/
https://lms.netacad.com/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}