#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)https?://(www\.)?([a-zA-Z0-9]+)(\.[a-zA-Z0-9.-]+)"
Local $sString = "https://www.google.com" & @CRLF & _
"https://regex101.com/" & @CRLF & _
"https://www.youtube.com/" & @CRLF & _
"https://www.udemy.com/" & @CRLF & _
"https://tm.udemy.com/" & @CRLF & _
"https://lms.netacad.com/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")