import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https?://(www\\.)?([a-zA-Z0-9]+)(\\.[a-zA-Z0-9.-]+)";
final String string = "https://www.google.com\n"
+ "https://regex101.com/\n"
+ "https://www.youtube.com/\n"
+ "https://www.udemy.com/\n"
+ "https://tm.udemy.com/\n"
+ "https://lms.netacad.com/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}