const regex = new RegExp('https?://(www\\.)?([a-zA-Z0-9]+)(\\.[a-zA-Z0-9.-]+)', 'gm')
const str = `https://www.google.com
https://regex101.com/
https://www.youtube.com/
https://www.udemy.com/
https://tm.udemy.com/
https://lms.netacad.com/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}