// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([\/\+][A-Za-z](-[0-9]+)+)").unwrap();
let string = "jkshd/asdf-asdf-34j/a-123+d-12334-234/woirjf";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}