using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\/\+][A-Za-z](-[0-9]+)+)";
string input = @"jkshd/asdf-asdf-34j/a-123+d-12334-234/woirjf";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}