$re = '/([\/\+][A-Za-z](-[0-9]+)+)/';
$str = 'jkshd/asdf-asdf-34j/a-123+d-12334-234/woirjf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);