package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([\/\+][A-Za-z](-[0-9]+)+)`)
var str = `jkshd/asdf-asdf-34j/a-123+d-12334-234/woirjf`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}