re = /([\/\+][A-Za-z](-[0-9]+)+)/
str = 'jkshd/asdf-asdf-34j/a-123+d-12334-234/woirjf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end