import Foundation
let pattern = ##"^(([:][a-z]+)?\s*([\+|\-]?)\s*(nop|mov|jmp|slp|slx|add|sub|mul|not|dgt|dst|teq|tgt|tlt|tcp)\s*(acc|dat|p[\d+]|x[\d+]|[\d+])\s*(acc|dat|p[\d+]|x[\d+]|[\d+])\s*|[#].*)"##
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
:label +mov acc dat This is a label and instruction with a conditional execution
+mov acc dat This is a
mov acc 1 awdasda
+mov acc dat
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)