import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(([:][a-z]+)?\\s*([\\+|\\-]?)\\s*(nop|mov|jmp|slp|slx|add|sub|mul|not|dgt|dst|teq|tgt|tlt|tcp)\\s*(acc|dat|p[\\d+]|x[\\d+]|[\\d+])\\s*(acc|dat|p[\\d+]|x[\\d+]|[\\d+])\\s*|[#].*)";
final String string = ":label +mov acc dat This is a label and instruction with a conditional execution\n"
+ "+mov acc dat This is a \n"
+ "mov acc 1 awdasda \n"
+ "+mov acc dat";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}