re = /^(([:][a-z]+)?\s*([\+|\-]?)\s*(nop|mov|jmp|slp|slx|add|sub|mul|not|dgt|dst|teq|tgt|tlt|tcp)\s*(acc|dat|p[\d+]|x[\d+]|[\d+])\s*(acc|dat|p[\d+]|x[\d+]|[\d+])\s*|[#].*)/mi
str = ':label +mov acc dat This is a label and instruction with a conditional execution
+mov acc dat This is a
mov acc 1 awdasda
+mov acc dat'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end