using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(([:][a-z]+)?\s*([\+|\-]?)\s*(nop|mov|jmp|slp|slx|add|sub|mul|not|dgt|dst|teq|tgt|tlt|tcp)\s*(acc|dat|p[\d+]|x[\d+]|[\d+])\s*(acc|dat|p[\d+]|x[\d+]|[\d+])\s*|[#].*)";
string input = @":label +mov acc dat This is a label and instruction with a conditional execution
+mov acc dat This is a
mov acc 1 awdasda
+mov acc dat";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}