const regex = /^(([:][a-z]+)?\s*([\+|\-]?)\s*(nop|mov|jmp|slp|slx|add|sub|mul|not|dgt|dst|teq|tgt|tlt|tcp)\s*(acc|dat|p[\d+]|x[\d+]|[\d+])\s*(acc|dat|p[\d+]|x[\d+]|[\d+])\s*|[#].*)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(([:][a-z]+)?\\s*([\\+|\\-]?)\\s*(nop|mov|jmp|slp|slx|add|sub|mul|not|dgt|dst|teq|tgt|tlt|tcp)\\s*(acc|dat|p[\\d+]|x[\\d+]|[\\d+])\\s*(acc|dat|p[\\d+]|x[\\d+]|[\\d+])\\s*|[#].*)', 'gmi')
const str = `:label +mov acc dat This is a label and instruction with a conditional execution
+mov acc dat This is a
mov acc 1 awdasda
+mov acc dat`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}