re = /^(.+?)\s(\/[^?]*)(\?([^&]+=[^&\s]+&?)+)?\sHTTP\/\d\.\d$/mi
str = 'GET /index.html?x=1&y=2 HTTP/1.1
GET /index.html HTTP/1.1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end