using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.+?)\s(\/[^?]*)(\?([^&]+=[^&\s]+&?)+)?\sHTTP\/\d\.\d$";
string input = @"GET /index.html?x=1&y=2 HTTP/1.1
GET /index.html HTTP/1.1";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}