import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.+?)\\s(\\/[^?]*)(\\?([^&]+=[^&\\s]+&?)+)?\\sHTTP\\/\\d\\.\\d$";
final String string = "GET /index.html?x=1&y=2 HTTP/1.1\n\n"
+ "GET /index.html HTTP/1.1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}