$re = '/^(.+?)\s(\/[^?]*)(\?([^&]+=[^&\s]+&?)+)?\sHTTP\/\d\.\d$/mi';
$str = 'GET /index.html?x=1&y=2 HTTP/1.1
GET /index.html HTTP/1.1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);