#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(.+?)\s(\/[^?]*)(\?([^&]+=[^&\s]+&?)+)?\sHTTP\/\d\.\d$"
Local $sString = "GET /index.html?x=1&y=2 HTTP/1.1" & @CRLF & _
"" & @CRLF & _
"GET /index.html HTTP/1.1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")