re = /(?:https?:?\/?\/?)?(\d+)[\.:](\d+)[\.:](\d+)[\.:](\d+)(?::\d+)?/
str = '194.58.120.176
http://194.58.120.176
https://194.58.120.176:80
https://194.58.120.176:443
194.58:120:176
194.58.120.176.1321'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end