$re = '/(?:https?:?\/?\/?)?(\d+)[\.:](\d+)[\.:](\d+)[\.:](\d+)(?::\d+)?/';
$str = '194.58.120.176
http://194.58.120.176
https://194.58.120.176:80
https://194.58.120.176:443
194.58:120:176
194.58.120.176.1321';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);