import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:https?:?\\/?\\/?)?(\\d+)[\\.:](\\d+)[\\.:](\\d+)[\\.:](\\d+)(?::\\d+)?";
final String string = "194.58.120.176\n"
+ "http://194.58.120.176\n"
+ "https://194.58.120.176:80\n"
+ "https://194.58.120.176:443\n"
+ "194.58:120:176\n"
+ "194.58.120.176.1321";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}