using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:https?:?\/?\/?)?(\d+)[\.:](\d+)[\.:](\d+)[\.:](\d+)(?::\d+)?";
string input = @"194.58.120.176
http://194.58.120.176
https://194.58.120.176:80
https://194.58.120.176:443
194.58:120:176
194.58.120.176.1321";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}