const regex = new RegExp('(?:https?:?\\/?\\/?)?(\\d+)[\\.:](\\d+)[\\.:](\\d+)[\\.:](\\d+)(?::\\d+)?', 'g')
const str = `194.58.120.176
http://194.58.120.176
https://194.58.120.176:80
https://194.58.120.176:443
194.58:120:176
194.58.120.176.1321`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}