import Foundation
let pattern = #"^(?i:25[0-5]|2[0-4]\d|1\d\d|\d\d|\d|any|tcp|udp|icmpv[46](?:[:](?:25[0-5]|2[0-4]\d|1\d\d|\d\d|\d),(?:25[0-5]|2[0-4]\d|1\d\d|\d\d|\d))?)(?:,(?i:25[0-5]|2[0-4]\d|1\d\d|\d\d|\d|any|tcp|udp|icmpv[46](?:[:](?:25[0-5]|2[0-4]\d|1\d\d|\d\d|\d),(?:25[0-5]|2[0-4]\d|1\d\d|\d\d|\d))?))*?$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"icmpV4:150,145,72"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}