import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?i:25[0-5]|2[0-4]\\d|1\\d\\d|\\d\\d|\\d|any|tcp|udp|icmpv[46](?:[:](?:25[0-5]|2[0-4]\\d|1\\d\\d|\\d\\d|\\d),(?:25[0-5]|2[0-4]\\d|1\\d\\d|\\d\\d|\\d))?)(?:,(?i:25[0-5]|2[0-4]\\d|1\\d\\d|\\d\\d|\\d|any|tcp|udp|icmpv[46](?:[:](?:25[0-5]|2[0-4]\\d|1\\d\\d|\\d\\d|\\d),(?:25[0-5]|2[0-4]\\d|1\\d\\d|\\d\\d|\\d))?))*?$";
final String string = "icmpV4:150,145,72";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}