use strict;
my $str = 'icmpV4:150,145,72';
my $regex = qr/^(?i:25[0-5]|2[0-4]\d|1\d\d|\d\d|\d|any|tcp|udp|icmpv[46](?:[:](?:25[0-5]|2[0-4]\d|1\d\d|\d\d|\d),(?:25[0-5]|2[0-4]\d|1\d\d|\d\d|\d))?)(?:,(?i:25[0-5]|2[0-4]\d|1\d\d|\d\d|\d|any|tcp|udp|icmpv[46](?:[:](?:25[0-5]|2[0-4]\d|1\d\d|\d\d|\d),(?:25[0-5]|2[0-4]\d|1\d\d|\d\d|\d))?))*?$/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}