re = /^(?i:25[0-5]|2[0-4]\d|1\d\d|\d\d|\d|any|tcp|udp|icmpv[46](?:[:](?:25[0-5]|2[0-4]\d|1\d\d|\d\d|\d),(?:25[0-5]|2[0-4]\d|1\d\d|\d\d|\d))?)(?:,(?i:25[0-5]|2[0-4]\d|1\d\d|\d\d|\d|any|tcp|udp|icmpv[46](?:[:](?:25[0-5]|2[0-4]\d|1\d\d|\d\d|\d),(?:25[0-5]|2[0-4]\d|1\d\d|\d\d|\d))?))*?$/
str = 'icmpV4:150,145,72'
# Print the match result
str.match(re) do |match|
puts match.to_s
end