// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\bp+[a@\*]?[e3\*\W_]+d+[\*0o](?:(?:ph|f)il(?:[e3\*\W_]|ia))?\b").unwrap();
let string = "p3do
pedo
pedophile
pedophilia
paedofile
pedofile
peeedophilia
pedophil3
p3d0
ped0
p*do
peedo
DO NOT CAPTURE
pedogogy";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}