use strict;
my $str = 'p3do
pedo
pedophile
pedophilia
paedofile
pedofile
peeedophilia
pedophil3
p3d0
ped0
p*do
peedo
DO NOT CAPTURE
pedogogy';
my $regex = qr/\bp+[a@\*]?[e3\*\W_]+d+[\*0o](?:(?:ph|f)il(?:[e3\*\W_]|ia))?\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}