const regex = /\bp+[a@\*]?[e3\*\W_]+d+[\*0o](?:(?:ph|f)il(?:[e3\*\W_]|ia))?\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bp+[a@\\*]?[e3\\*\\W_]+d+[\\*0o](?:(?:ph|f)il(?:[e3\\*\\W_]|ia))?\\b', 'gm')
const str = `p3do
pedo
pedophile
pedophilia
paedofile
pedofile
peeedophilia
pedophil3
p3d0
ped0
p*do
peedo
DO NOT CAPTURE
pedogogy`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}