import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bp+[a@\\*]?[e3\\*\\W_]+d+[\\*0o](?:(?:ph|f)il(?:[e3\\*\\W_]|ia))?\\b";
final String string = "p3do\n"
+ "pedo\n"
+ "pedophile\n"
+ "pedophilia\n"
+ "paedofile\n"
+ "pedofile\n"
+ "peeedophilia\n"
+ "pedophil3\n"
+ "p3d0\n"
+ "ped0\n"
+ "p*do\n"
+ "peedo\n\n"
+ "DO NOT CAPTURE\n"
+ "pedogogy";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}