package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bp+[a@\*]?[e3\*\W_]+d+[\*0o](?:(?:ph|f)il(?:[e3\*\W_]|ia))?\b`)
var str = `p3do
pedo
pedophile
pedophilia
paedofile
pedofile
peeedophilia
pedophil3
p3d0
ped0
p*do
peedo
DO NOT CAPTURE
pedogogy`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}