// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^https:\/\/(www\.)?[-a-zA-Z0-9@:%._+~#=]{1,256}\.[a-zA-Z0-9()]{1,6}\b([-a-zA-Z0-9()@:%_+.~#?&//=]*)$").unwrap();
let string = "https://www.google.com
https://google.com
https://test.example.com
https://dashboard-staging.com
https://dashboard-staging.com/bro/good
www.google.com
fgdsfdsf
ffdsf.com
fsdfs.comfsfds
.cfom
http://dashboard-staging.com";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}