const regex = /^https:\/\/(www\.)?[-a-zA-Z0-9@:%._+~#=]{1,256}\.[a-zA-Z0-9()]{1,6}\b([-a-zA-Z0-9()@:%_+.~#?&//=]*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^https:\\\/\\\/(www\\.)?[-a-zA-Z0-9@:%._+~#=]{1,256}\\.[a-zA-Z0-9()]{1,6}\\b([-a-zA-Z0-9()@:%_+.~#?&\/\/=]*)$', 'gm')
const str = `https://www.google.com
https://google.com
https://test.example.com
https://dashboard-staging.com
https://dashboard-staging.com/bro/good
www.google.com
fgdsfdsf
ffdsf.com
fsdfs.comfsfds
.cfom
http://dashboard-staging.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}