use strict;
my $str = 'https://www.google.com
https://google.com
https://test.example.com
https://dashboard-staging.com
https://dashboard-staging.com/bro/good
www.google.com
fgdsfdsf
ffdsf.com
fsdfs.comfsfds
.cfom
http://dashboard-staging.com';
my $regex = qr/^https:\/\/(www\.)?[-a-zA-Z0-9@:%._+~#=]{1,256}\.[a-zA-Z0-9()]{1,6}\b([-a-zA-Z0-9()@:%_+.~#?&//=]*)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}