#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^https:\/\/(www\.)?[-a-zA-Z0-9@:%._+~#=]{1,256}\.[a-zA-Z0-9()]{1,6}\b([-a-zA-Z0-9()@:%_+.~#?&//=]*)$"
Local $sString = "https://www.google.com" & @CRLF & _
"https://google.com" & @CRLF & _
"https://test.example.com" & @CRLF & _
"https://dashboard-staging.com" & @CRLF & _
"https://dashboard-staging.com/bro/good" & @CRLF & _
"www.google.com" & @CRLF & _
"fgdsfdsf" & @CRLF & _
"ffdsf.com" & @CRLF & _
"fsdfs.comfsfds" & @CRLF & _
".cfom" & @CRLF & _
"http://dashboard-staging.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")