$re = '/^https:\/\/(www\.)?[-a-zA-Z0-9@:%._+~#=]{1,256}\.[a-zA-Z0-9()]{1,6}\b([-a-zA-Z0-9()@:%_+.~#?&//=]*)$/m';
$str = 'https://www.google.com
https://google.com
https://test.example.com
https://dashboard-staging.com
https://dashboard-staging.com/bro/good
www.google.com
fgdsfdsf
ffdsf.com
fsdfs.comfsfds
.cfom
http://dashboard-staging.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);