// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\[\D+\d\s*\D.*").unwrap();
let string = "[F3- Salir]
[ F6 - Documento Material > ]
[ F7 - Entrega Distribucion > ]
[ F9 - Documento Inventario > ]
[ F8 - Validacion Documento > ]
[ F2 - Varios > ]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}