re = /\[\D+\d\s*\D.*/m
str = '[F3- Salir]
[ F6 - Documento Material > ]
[ F7 - Entrega Distribucion > ]
[ F9 - Documento Inventario > ]
[ F8 - Validacion Documento > ]
[ F2 - Varios > ]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end