package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[\D+\d\s*\D.*`)
var str = `[F3- Salir]
[ F6 - Documento Material > ]
[ F7 - Entrega Distribucion > ]
[ F9 - Documento Inventario > ]
[ F8 - Validacion Documento > ]
[ F2 - Varios > ]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}