#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\[\D+\d\s*\D.*"
Local $sString = "[F3- Salir]" & @CRLF & _
"[ F6 - Documento Material > ]" & @CRLF & _
"[ F7 - Entrega Distribucion > ]" & @CRLF & _
"[ F9 - Documento Inventario > ]" & @CRLF & _
"[ F8 - Validacion Documento > ]" & @CRLF & _
"[ F2 - Varios > ]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")