import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[\\D+\\d\\s*\\D.*";
final String string = "[F3- Salir]\n"
+ "[ F6 - Documento Material > ]\n"
+ "[ F7 - Entrega Distribucion > ]\n"
+ "[ F9 - Documento Inventario > ]\n"
+ "[ F8 - Validacion Documento > ]\n"
+ "[ F2 - Varios > ]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}