// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[0-7]\.|^8.([0-3][0-9]|4[0-3]|44.0.([0-3][0-9]))").unwrap();
let string = "8.44.0.39
8.43.0.56
8.44.0.55";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}